Evo X ECU problem

View previous topic View next topic Go down

Evo X ECU problem

Post by bandit76544 on Mon Sep 10, 2012 8:55 pm

I have a 2010 Evo GSR. When i went to the dealer to get it, it was already modified with aftermarket intercooler piping and intake. I had the dealership remove all the aftermarket parts and return it to stock (didn't want to buy someone else's headache). The problem is that the previous owner had the ECU flashed, im guessing to go along with the parts added. Now that it is with stock parts only im looking for advice on how to return the ECU to stock. The local dealer VIVA says its hit or miss depending on the program used to flash the ECU. I have no idea if it was flashed with a handheld like Cobb access port or a computer. What i do know is that the idle is about 200 or 300 rpm above normal and there are no factory limiters. ie 5500rpm limit at idle or 155mph cut off.

bandit76544
AWD Noobie

Posts : 2
Reputation : 0
Join date : 2012-09-10
Location : El Paso, Tx

View user profile

Back to top Go down

Re: Evo X ECU problem

Post by STi2eNvy on Tue Sep 11, 2012 1:22 am

Hmm, If it was a cobb accessport then most likely it still would have been in the car because you have to unmarry to sell it or anything. I would have just left those parts on the car as that is just very very minor bolt on pieces that probably were better for the car Very Happy

_________________
Organizer of EPAWD
2005 Mineral White Subaru STi
2006 Mini Cooper S Hatchback
2010 Mini Cooper S Laurel Sport Convertible
2010 Black Mica Mazda RX8 Coupe
avatar
STi2eNvy
Community Founder =)

Posts : 1294
Reputation : 64
Join date : 2012-03-19
Age : 28
Location : El Paso, TX

View user profile http://epawd.forumotion.com

Back to top Go down

Re: Evo X ECU problem

Post by bandit76544 on Tue Sep 11, 2012 10:18 pm

Well im gonna take it to the dealership on friday so hopefully they can reflash it.

bandit76544
AWD Noobie

Posts : 2
Reputation : 0
Join date : 2012-09-10
Location : El Paso, Tx

View user profile

Back to top Go down

Re: Evo X ECU problem

Post by alloutEVO on Tue Sep 18, 2012 5:38 pm

#1 how do you know that it was flashed by the prev owner? if so do you have contact or can get in contact with the prev owner?

#2 what issues is this causing the car? what symptoms are you seeing?

#3 do you want to sell those aftermarket parts Smile ?

_________________
-Option R-
"Heavy foot, empty head."
avatar
alloutEVO
EPAWD Frequent Flyer

Posts : 207
Reputation : 13
Join date : 2012-06-05
Location : El Paso TX

View user profile

Back to top Go down

Re: Evo X ECU problem

Post by STi2eNvy on Tue Sep 18, 2012 11:20 pm

alloutSTI wrote: #3 do you want to sell those aftermarket parts Smile ?


Lmao good idea you had there Very Happy

_________________
Organizer of EPAWD
2005 Mineral White Subaru STi
2006 Mini Cooper S Hatchback
2010 Mini Cooper S Laurel Sport Convertible
2010 Black Mica Mazda RX8 Coupe
avatar
STi2eNvy
Community Founder =)

Posts : 1294
Reputation : 64
Join date : 2012-03-19
Age : 28
Location : El Paso, TX

View user profile http://epawd.forumotion.com

Back to top Go down

Re: Evo X ECU problem

Post by FuegoMS on Thu Oct 11, 2012 11:47 am

Another MITSU owner with VIVA issues... lol... Sorry I don't do buisness with VIVA anymore. I take my car to mitsu in Las Cruses. Also, if you need your Evo flashed back to normal, I should be able to help you with that. I have an Openport and would just have to get you the stock ECU tune of of the Evo forum and it should fix u up.

Here is my car and the VIVA story incase anyone wants to know. lol
http://forums.evolutionm.net/09-lancer-ralliart-general/581146-fuegos-project-car.html

My friend and I both feel that Sisbarro Volkswagen Mitsubishi is 100x better than VIVA, customer support has always been awesome. They are located here: 1115 South Valley Drive, Las Cruces, NM (575) 524-3561

FuegoMS
AWD Noobie

Posts : 15
Reputation : 0
Join date : 2012-09-27
Age : 34
Location : NE, El Paso

View user profile

Back to top Go down

Re: Evo X ECU problem

Post by PurpleEvo on Sat Oct 27, 2012 3:44 pm

FuegoMS,

I too have been inactive with the some of the meets because of school and most importantly this week because of my car. It may be coincidence but my car is at Viva, I took it in for three things: 1) oil/filter change, 2) engine cleaning, and 3) front sway install.

I tried to pick it up but my car did not function properly, I had the traction control light symbol come up on the infometer of the dashboard. Regardless of what, Viva was kind enough to keep the car and work on it. Bottom line, I was impressed by how nice the service manager was to me and I replicated the problem to him by test driving the vehicle with him in the vehicle. We will see, more to follow. Wish me luck.

V/r

PurpleEvo

PurpleEvo
AWD Noobie

Posts : 17
Reputation : 6
Join date : 2012-07-30

View user profile

Back to top Go down

Re: Evo X ECU problem

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum